The deployment issues in europe-west2 have been fully resolved.
All deployment pipelines are operating normally. We appreciate your patience while we worked through this.
Posted Jun 06, 2026 - 20:52 UTC
Monitoring
A fix has been implemented and deployed to resolve the stuck deployment issues in europe-west2.
Deployments are now processing normally, and the previous workaround (cloning the application) is no longer required. We are monitoring the platform closely to ensure full stability.
Posted Jun 06, 2026 - 20:25 UTC
Identified
The root cause of the stuck deployments in europe-west2 has been identified. Our engineering team is currently working on a fix to restore normal deployment behavior.
Posted Jun 06, 2026 - 20:09 UTC
Investigating
We are currently investigating an issue causing active deployments to become stuck in the europe-west2 region.
Impact: Existing applications attempting to redeploy or update may experience indefinite hangs. Initial (first-time) deployments are unaffected.
Workaround: If this is severely impacting your operations, you can bypass the issue by cloning your application and triggering a fresh deployment on the cloned instance.
Our engineering team is actively hunting for the root cause. We will provide next updates as soon as we have more information.