Temporary halt on new application and preview deployment

Incident Report for Sevalla

Resolved

We are happy to confirm that the issue affecting the provisioning of new applications and preview deployments has been resolved.

Our infrastructure provider, Cloudflare, has successfully increased our DNS record quota. All deployment operations should now be functioning normally.

We apologize for the service disruption and thank you for your patience while we worked to resolve this with our vendor.
Posted Sep 30, 2025 - 08:05 UTC

Identified

We are currently experiencing an issue that is preventing the creation of any new applications or preview deployments.

This is due to hitting our DNS record quota on our Cloudflare account, which is blocking the automated DNS entry creation required for new application deployment. Existing applications are unaffected and continue to operate normally.

Our team is actively working to resolve this. We are in the process of escalating a request with Cloudflare to increase our quota and are also auditing existing DNS records for potential cleanup.
Posted Sep 30, 2025 - 07:36 UTC
This incident affected: Applications.