404 error on applications and static sites

Incident Report for Sevalla

Resolved

Our services appeared stable during monitoring. Cloudflare has set its incident status to resolved, and the remaining GCP issues do not affect our services.
Posted Jun 12, 2025 - 21:53 UTC

Monitoring

All of our providers have stated that they restored their services and are monitoring them.
Posted Jun 12, 2025 - 21:36 UTC

Update

Most applications and static sites have started to recover and become available, but some of our services/locations may still be affected by the outage. We're continuing to follow the updates from our providers.
Posted Jun 12, 2025 - 20:23 UTC

Update

Cloudflare: We are starting to see services recover. We still expect to see intermittent errors across the impacted services as systems handle retried and caches are filled.
Posted Jun 12, 2025 - 19:19 UTC

Update

Posted Jun 12, 2025 - 19:05 UTC

Update

We are still waiting for any update on the Cloudflare service outage.
Posted Jun 12, 2025 - 18:57 UTC

Update

We are working with Cloudflare on this issue.
Posted Jun 12, 2025 - 18:22 UTC

Identified

Update

The issue seems to be with our firewall provider, Cloudflare. We are working with them to find a resolution at this time.
Posted Jun 12, 2025 - 18:19 UTC

Investigating

We are currently investigating this issue.
Posted Jun 12, 2025 - 18:13 UTC
This incident affected: Applications and Static sites.