Google Cloud has updated its status page to indicate elevated latency issues and error rates in us-east1, possibly due to a hardware problem. We are continuing to monitor this incident and apologize for any inconvenience caused.
Posted Jul 18, 2025 - 16:06 UTC
Investigating
We experience failed requests in us-east1 cluster. We are investigating the issue.
Posted Jul 18, 2025 - 15:38 UTC
This incident affected: Applications and Databases.