Cloudflare Network Issues

Incident Report for Sevalla

Resolved

This incident has been resolved.
Posted Dec 19, 2025 - 14:22 UTC

Update

Our analytics show healthy response levels, so we are now closing this incident.
Posted Dec 19, 2025 - 14:21 UTC

Monitoring

Cloudflare has marked the incident as resolved. We will continue to monitor the situation closely to ensure everything remains stable.
Posted Dec 19, 2025 - 14:03 UTC

Update

Cloudflare deployed a potential fix and is currently monitoring the outcome. We will continue to track Cloudflare's status and provide updates as they become available.
Posted Dec 19, 2025 - 13:15 UTC

Identified

Our upstream provider, Cloudflare, is currently experiencing network issues that are affecting some of our services. Customers may encounter downtime for their workloads or have difficulty accessing our dashboard at app.sevalla.com.

You can see the latest updates from Cloudflare over here:
https://www.cloudflarestatus.com/incidents/msv92vykgtvp
Posted Dec 19, 2025 - 12:36 UTC
This incident affected: Dashboard, Applications, and Static sites.