404 errors on Cloudflare Proxied (O2O) static sites

Incident Report for Sevalla

Resolved

We now consider this incident resolved. If you disabled your Cloudflare proxy as a workaround, you may now try to safely re-enable it.
Posted Mar 12, 2026 - 12:49 UTC

Monitoring

We have deployed a fix for the 404 errors affecting proxied domains. We are currently monitoring the results. If you are still experiencing issues with your proxied setup, please let us know.
Posted Mar 12, 2026 - 11:49 UTC

Update

We are continuing to investigate the root cause and are working toward a resolution.
Posted Mar 12, 2026 - 11:31 UTC

Identified

Update: We have identified that this issue specifically affects domains using a Cloudflare "Orange-to-Orange" (proxied) setup.

Workaround: Disabling the Cloudflare proxy (switching to "DNS only" / Grey Cloud) for affected domains resolves the 404 errors.

Customers using Cloudflare for DNS only, or those not using Cloudflare, remain unaffected. We are continuing to investigate the underlying cause and will provide further updates as they become available.
Posted Mar 12, 2026 - 10:04 UTC

Investigating

We are investigating reports of intermittent 404 errors affecting our Static Site Hosting service. Our team is working to identify the root cause.
Posted Mar 12, 2026 - 09:23 UTC
This incident affected: Static sites.